Comma delimiter issues

Sep 7, 2012 at 9:16 AM

I'm trying to convert a DB that has "doubles" (floating point) numbers in a table.

Overhere in Europe we use , (comma), in the US they use a . (point) as delimiter.

Is there some way I can manipulate the settings.xml file (or another way) to avoid the double numbers being converted to comma's in the SQL insert statements.

The insert statements are failing of course because every insert has more parameters than there are columns in the table.

so in short:

15.25 is now converted as 15,25

in the insert we see then :

INSERT INTO MYTABLE (COLUMN1, COLUMN2, MYNUMBER) VALUES ('some value', 'another value', 15,25)

which fails because that last value should be 15.25

Please help...

Sep 7, 2012 at 4:04 PM

The trick to by pass this problem is to quickly set your local settings to US, then convert the DB and then put your local settings back.